Widespread outages - Northern New South Wales and Queensland

Major incident Broadband NSW QLD
07-03-25 11:06 AEDT · 1 week, 3 days, 2 hours, 11 minutes

Updates

Resolved

This notification is to inform you that the recent unplanned network issue impacting service on the XYZ Telecom network has now been resolved as per below:

Title: Widespread outages - Northern New South Wales and Queensland

Current Status: Service Restoration

Date & Time Started: March 7, 2025 08:01AM
Date & Time Resolved: March 17, 2025 12:37PM

Resolution Update: The outage caused by Cyclone Alfred has been resolved. Power services in Northern New South Wales and Queensland have been restored, and all systems are now fully operational.

Once again, the XYZ Telecom support team thank you for your patience and understanding in this matter.

Should your customers still be experiencing any issues please raise a support request as per the normal fault reporting process.

Regards
XYZ Telecom

17-03-25 · 12:57 AEDT
Update

Please find below the latest update from XYZ Telecom on the unplanned network issue impacting services delivered to your customers:

Title: Widespread outages - Northern New South Wales and Queensland

Current Status: Ongoing Service Disruption

Date & Time Started: March 7, 2025 08:01AM
Date & Time Resolved: Ongoing

Estimated time of resolution: Unknown

Latest Update Information:

Affected sites:

  • Doubleview Drive, Elanora, QLD
  • Nineteenth Avenue, Palm Beach, QLD
  • Wongawallan Drive, Upper Coomera, QLD
  • Seaview Road, Mount Cotton, QLD
  • Bayview Street, Runaway Bay, QLD
  • Pearl Street, Kingscliff, NSW

Note: Services in this general area are impacted.

The XYZ Telecom support team are currently working to resolve this issue as soon as possible, we will provide further updates as information becomes available.

We thank you for your patience and understanding in this matter.

Regards
XYZ Telecom

11-03-25 · 18:24 AEDT
Issue

Due to Cyclone Alfred, many upstream provider services within the Northern New South Wales and Queensland network have been affected by power outages.
Inclement weather and flooding is currently restricting respective field engineers from accessing equipment in order to perform necessary remedial activities.
Currently, the energy providers restoration time is unknown.

07-03-25 · 11:06 AEDT

← Back